OS4 DepotLogo by Alkaron 
(anonymous IP: 3.226.248.180,1550) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (331)
   o Datatype (50)
   o Demo (188)
   o Development (555)
   o Document (21)
   o Driver (90)
   o Emulation (143)
   o Game (903)
   o Graphics (477)
   o Library (103)
   o Network (212)
   o Office (60)
   o Utility (837)
   o Video (64)

Total files: 4034

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Graphics » Icon » weblinks.lha

Web Links

Description: Easy Web/Bookmarks Links Icons
Download: weblinks.lha
Version: 2.0
Date: 29 Oct 2013
Category: graphics/icon
FileID: 8386
RSS Feed url: http://www.os4depot.net/modules/comments/rssfeed.php?file=graphics/icon/weblinks.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: amigang (86.165.245.101)At: 27 Oct 2013, 15:00File version: 1.0
Thanks for the comments guys, still at the very beginning of my programming adventure I will look into implentmenting one of these and make an update in the doc about the now many different ways I've learned how to do this. Thanks
 
 
Comment by: Severin (31.185.200.187)At: 26 Oct 2013, 20:10File version: 1.0
urlopen should be used as default though and it's always available, only people with OS4.0 need openurl

If exists "c:urlopen"
urlopen "http://www.amigaworld.net"
else
openurl "http://www.amigaworld.net"
endif

That will never fail on 4.1 and on 4.0 will open a console reporting openurl not found if it's not installed.

If you want a neater solution still using a script just use a script like:

.bra {
.ket }
.key url
If exists "c:urlopen"
urlopen "{url}"
else
if exists "c:openurl"
openurl "{url}"
else
echo "OpenURL Not installed."
endif
endif

Then in the icons have the script as the default tool, run in shell mode without prompting for input, put the url in a tooltype.

Don't forget to set the S bit on the script

I've not tested this but you should be able to use the same script with all the icons.
 
 
Comment by: djrikki (80.5.186.220)At: 26 Oct 2013, 14:41File version: 1.0
Another script solution would be:

if exists sys:c/OpenURL
if exists libs:openurl.library
openurl "http://www.amigaworld.net"
endif
else
urlopen "http://www.amigaworld.net"
endif
 
 
Comment by: djrikki (80.5.186.220)At: 26 Oct 2013, 14:36File version: 1.0
Both of the Twitter and Facebook logos are out of date and the amigaworld logo is clearly squeezed horizontally. Nice idea.
 
 
Comment by: Severin (31.185.200.187)At: 26 Oct 2013, 13:08File version: 1.0
You can easily remove the dependency on iconx by doing the following:-

Open the icon onformation.
Turn the script protection bit on.
Go to the icon tab and delete the default tool.
Change 'start from' to shell, turn off prompt for input

Another way to do it is:-
just have an icon with the url as the name eg. os4depot.net.info
set the default tool to urlopen
and a tooltype of "PROTOCOL=HTTP"

No need to set the script bit and just run it in workbench mode.

 
 

Copyright © 2004-2020 by Björn Hagström All Rights Reserved