OS4 DepotLogo by Nickman 
(anonymous IP: 34.238.189.171,1344) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (330)
   o Datatype (47)
   o Demo (186)
   o Development (540)
   o Document (21)
   o Driver (89)
   o Emulation (142)
   o Game (872)
   o Graphics (468)
   o Library (102)
   o Network (205)
   o Office (56)
   o Utility (825)
   o Video (61)

Total files: 3944

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Video » Play » liveforit-mplayer.lha

LiveForIt-mplayer

Description: Mplayer optimized for Radeon HD
Download: liveforit-mplayer.lha
Version: 6.4
Date: 14 Jan 2015
Category: video/play
FileID: 9120
RSS Feed url: http://www.os4depot.net/modules/comments/rssfeed.php?file=video/play/liveforit-mplayer.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: hotrod (185.57.4.21)At: 24 Feb 2015, 07:17File version: 6.4
Playing with resizing the window, try making it as thins as possible and you'll see a freeze.
 
 
Comment by: hotrod (185.57.4.21)At: 19 Jan 2015, 06:57File version: 6.4
p96_pip is working fine here now when used with smTube (A1 XE, Radeon 9250). Default audio option doesn't play in synch but using "-ao sdl" does work. One thing though, when pressing "f" for fullscreen and "f" again to get back to window mode, sometimes you get the window but it fills up the whole screen instead of going back to 480p.
 
 
Comment by: samo79 (93.144.94.200)At: 14 Jan 2015, 20:32File version: 6.4
A few problems about the new 6.4 (tested on a plain Sam440ep Flex + Radeon 9250)

1 - OSD doesn't work in P96_pip video output.

2 - Version command is not updated (it still says MPlayer 6.3 rathen then 6.4)

3 - P96_pip video output still having the tedious white stripes all around, would be cool if you can include the fix from the p96_pip (MUI MPlayer driver) --> ask kas1e for the code

4 - By default in MPlayerGUI (Video output: Default) MPlayer opens the video using the cgx_wpa, instead would be more logic to use "p96_pip" by default instead

Still of course many other little things you may adjust (see the bugtracker) but that are the things i have found for now :-)

Good job
 
 
Comment by: hotrod (185.57.4.21)At: 12 Jan 2015, 07:44File version: 6.3
A big thank you! This version seems to be able to stream clips from youtube and still being rockstable :) .
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 04 Jan 2015, 16:35File version: 6.3
Here is way really hate the comments-
1. I can't quote you.
2. You can post output logs, I do not see way things are not working for you.
3. I do not get any PM/E-mail or notification when someone has posted anything.
4. I have many file uploads on the Depot; I do not want to go around checking etch for comments.
So please use the forums, if you like to get support.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 04 Jan 2015, 16:16File version: 6.3
@djrikki
You need to pick the one that is correct for your computer AltiVec or None AltiVec, Yes none AltiVec is a lot slower the AltiVec, and I am not responsible for SmTube, ask zzd10h if you have problems with it.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 04 Jan 2015, 16:09File version: 6.3
Can you people please use the forums; I do not check the file depot for comments.
http://www.amigans.net/modules/xforum/viewtopic.php?topic_id=6789&forum=3
 
 
Comment by: ddni (31.48.152.78)At: 04 Jan 2015, 12:22File version: 6.3
@djrikki go to smtube/amiga and edit PlayRexx.video to point to the new mplayer. I had to set -vo comp as the default is -vo yuv2 which gives me a gray screen.
 
 
Comment by: djrikki (80.5.186.220)At: 04 Jan 2015, 12:12File version: 6.3
Kjetil Hvalstrand, how can this be adapted to support SMTube? These multiple mplayer build are a distraction.
 
 
Comment by: djrikki (80.5.186.220)At: 04 Jan 2015, 11:56File version: 6.3
PS. And thats with the 2.4 drivers.
 
 
Comment by: djrikki (80.5.186.220)At: 04 Jan 2015, 11:55File version: 6.3
DDni, change video output in mplayer-gui to YUV-2 threaded. Okay, using Big Buck Bunny as a test subject, 720p playback on AmigaOne 500 has moved from 'very slow' to 'slow' - it still can't keep up with the audio so slightly (an understatement) disappointed.
 
 
Comment by: HKvalhe (80.213.3.116)At: 04 Jan 2015, 11:33File version: 6.3
Well, i'm certainly not the author of MPlayer, but yes i would believe you would also need RadeonHD 2.4 under AmigaOS 4.1 Final, to make full use of the new video features, which i assume is logical. I'm sure the author will confirm the same.
 
 
Comment by: Ddni (31.48.152.78)At: 04 Jan 2015, 11:07File version: 6.3
I have FE, but new outputs just give ma grey output. Perhaps Radeon 2.4 is also needed?
 
 
Comment by: HKvalhe (80.213.3.116)At: 04 Jan 2015, 09:18File version: 6.3
I'm still waiting for my AmigaOS 4.1 Final to arrive. I suspect after the weekend i should receive it. It's good to know that this version of MPlayer needs AmigaOS 4.1 Final to run, due to new video outputs :)
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 03 Jan 2015, 22:13File version: 6.3
AmigaOS4.1 Final is needed to use the new video outputs.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 28 May 2014, 19:01File version: 5.1
@SteveH I think you should ask that question in the forums, I don't think its a MPlayer problem, and even if it is, this not right place to get support.
 
 
Comment by: SteveH (81.132.174.15)At: 27 May 2014, 17:47File version: 5.1
I've tried that (in AHI Prefs, both Unit 0 and Music Unit set to 'HDaudio HiFi 32bit') but still no audio from MPlayer when I use the front audio connector.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 27 May 2014, 04:33File version: 5.1
 
 
Comment by: SteveH (86.182.43.28)At: 25 May 2014, 13:56File version: 5.1
Is it possible to redirect audio output to the X1000's HD audio device? I can only seem to get it to use my soundcard.
 
 
Comment by: HKvalhe (80.213.142.202)At: 21 May 2014, 21:04File version: 5.1
@Kjetil Hvalstrand
Thank you so much for advicing me to stick with the ARGB when using RadeonHD card as i do. Good point you mentioned that now, before i was thinking of trying RGB. It's good to know why this difference is important. Thank you so much :) ARGB it is :)
 
 
Comment by: zzd10h (77.195.182.178)At: 21 May 2014, 20:58File version: 5.1
Thank you Kjetil,
with this new version and "-cache" support I can play 720p YouTube video with SMTube on my low internet bandwith.
Bravo !
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 21 May 2014, 18:31File version: 5.1
Good question Hkvalhe, Mplayer-GUI does not know about that option yet, as it has no way of knowing unless its hardcoded, but Deniil 715 made it possible to supply additional parameters in the Extras tab.
So simply type -vo comp:rgb in the additional parameters and set Video output to default, this should work.
Don't use rgb option unless you have a older Radion card like the Radion 9250 card, RadionHD cards works best whit just comp or comp::argb.
 
 
Comment by: HKvalhe (80.213.142.202)At: 21 May 2014, 11:24File version: 5.1
Just one question. I'm using the MPlayer-GUI with this new Composite driver, but how to toggle the option of RGB or ARGB. Which of these are the best? I appreciate the help i can get :) Love this player!
 
 
Comment by: HKvalhe (80.213.142.202)At: 21 May 2014, 10:59File version: 5.1
Thank you again for this new version! Just getting better and better. Keep up the excellent work :)
 
 
Comment by: Petrol (86.192.41.94)At: 17 May 2014, 20:32File version: 4.2
Thank you for this nice version. Keep up the good work!

Regards,
Xavier.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 16 May 2014, 15:02File version: 4.2
@Hypex
Yes it works out of the box if you have one graphic card, if you have two you most promote mplayer to a mode you like, CLI options for doing it is broken ATM. If you want to just click on movies you most create a project icon, set the tooltype of mplayer, you can do that for all defiocns in deficons prefs.
 
 
Comment by: Hypex (210.4.227.134)At: 14 May 2014, 13:19File version: 4.2
Good work for an X1000 MPlayer. Does this work out of the box? I mean can it work wihout needing CLI options or specific tooltypes to open up on a RadeonHD screen? (Without the hardware driver ATM.)
 
 
Comment by: HKvalhe (80.213.142.202)At: 13 May 2014, 20:34File version: 4.1
@Kjetil Hvalstrand
I do understand and fully respect that. I like your new MPlayer anyway. It's great and it's getting better and better. I also like the new Composite driver. Keep up the excellent work! :) I'm happy that i have donated for it. I'm running the latest version 4.2 :)

The drawer icon with the new MPlayer logo is great, but too big. Could you make it in the same size as the normal OS4 icons you see out there, but with that logo matching that look? :) Unfortunately, i'm not a programmer or a coder. I don't have that knowledge and will never have. I'm also getting too old. I'm just an allround user. My talents are into writing like a writer and photographing. I leave all these hi-tech programming stuffs to much more talented people like you, Kjetil :) You are doing great :)
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 12 May 2014, 02:58File version: 2.1
@HKvalhe
I do not have time even look at DVD code, I do not have time to contact Stephen, nor do I think its usefull to contact Stephen as DvPlayer is not based on Mplayer source code, I spend my time on what I like to spend my free time on, thats not DVD code in MPlayer.
This project is NOT paying for my expenses.
When or if I do it, it will be when like to or have time to do it, and one more thing I don't care if you use DvPLayer or MPlayer, I like Mplayer and thats way I do it NOT becouse I want YOU to use MPlayer, thank you for your understanding. if you have free time learn to program, and spend your free time on getting DVD code working.
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 12 May 2014, 02:55File version: 2.1
@HKvalhe
I do not have time even look at DVD code, I do not have time to contact Stephen, nor do I think its usefull to contact Stephen as this DvPlayer is not based on Mplayer source code, I spend my time on what I like to spend my free time on, thats not DVD code in MPlayer.
This project is NOT paying for my expenses.
When or if I do it, it will be when like to or have time to do it, and one more thing I don't care if you use DvPLayer or MPlayer, I like Mplayer and thats way I do it NOT becouse I want YOU to use MPlayer, thank you for your understanding. if you have free time learn to program, and spend your free time on getting DVD code working.
 
 
Comment by: HKvalhe (80.213.142.202)At: 11 May 2014, 09:18File version: 2.1
Sorry for slow feedback, but could it interest you to contact Stephen Fellner, the author of DVPlayer? Perhaps he can give you an instruction in how the DVD playback in DVPlayer was done, and simply adopt that idea into MPlayer for DVD playback, using the Composite driver? :) It could be interesting :) Stephen Fellner actually told me that he is looking into the possibility to incorporate Composite driver in his DVPlayer for a future version, when that will be :)
 
 
Comment by: Kjetil Hvalstrand (81.167.17.251)At: 03 May 2014, 00:35File version: 2.1
Yes DVD stuff, I have not looked into that, don't know whats going on, so can't say, only really worked on video output part most of the time, latter version of LiveForIt-Mplayer is compiled whit cache, should help for streamed video.
 
 
Comment by: HKvalhe (80.213.142.202)At: 13 Apr 2014, 19:12File version: 1.1
I did an interesting discovery with this MPlayer and Composite. It's fully possible to watch a DVD-movie, as i have a Sillicon Image 3512 SATA controller. It was allocating this correctly when i picked the choice, but running a DVD movie appears quite slow.

Since this new MPlayer and Composite still are BETA, i suppose all this will improve when both MPlayer and Composite driver are to be released in FULL version. The discovery was interesting, however, especially that it should be able to play in full screen, if it only was playing smoothly :)
 
 
Comment by: HKvalhe (80.213.142.202)At: 09 Apr 2014, 20:09File version: 1.1
I have removed the old MPlayer and installed this new liveforit-mplayer. I renamed the liveforit-mplayer drawer to MPlayer, and have put the MPlayer-GUI and the banner.png into the drawer as well. It now works very well with the MPlayer-GUI, using Composite.

Thank you for bringing it, LiveForIt :) Great work! :) Composite is a lot faster! :)
 
 
Comment by: Jurassicc (86.184.166.10)At: 09 Apr 2014, 18:54File version: 1.1
Great update over the older versions thanks.

is http stream supported ? Eg: listening to radio streams.
Current version gives an please insert http: warning.
eg:-
mplayer http://www.radio6581.com/files/Radio6581.m3u
 
 
Comment by: LiveForIt (81.167.17.251)At: 09 Apr 2014, 18:47File version: 1.1
Andrea Palmate did NOT have support for MUI, your thinking of MplayerGUI yes it should work whit it.
 
 
Comment by: HKvalhe (80.213.142.202)At: 09 Apr 2014, 18:35File version: 1.0
Mistakes can happen to everyone. Good thing it will be recompiled :) Could you also enable the MUI-based GUI for this new MPlayer, both the Altivec and the Generic (non-Altivec) version, just like the original MPlayer by Andrea Palmate? :)
 
 
Comment by: LiveForIt (81.167.17.251)At: 09 Apr 2014, 17:19File version: 1.0
Sorry, some thing went wrong while compiling the none AltiVec version, recompiling now.
 
 
Comment by: AmigaRichard (80.7.138.115)At: 09 Apr 2014, 17:01File version: 1.0
It would be really good if this could be Optimised for a AmigaOne 500 :-)
 
 
Comment by: HKvalhe (80.213.142.202)At: 09 Apr 2014, 16:41File version: 1.0
Very interesting and promising, but could you do it the way it was done with the first MPlayer, with the possibility to use the MUI-based GUI that is in the tooltypes of the MPlayer? Also, make a Generic version of MPlayer to use with systems like SAM460ex, along with the new Composite driver. Otherwise, it looks promising :)
 
 

Copyright © 2004-2019 by Björn Hagström All Rights Reserved